Bad at naming

I admit that I have problem in naming functions. I don’t know why I cannot find concise words that will make my functions easier to understand, and at the same time using least words possible.

I usually go over clarity over shortness, thus my latest function I wrote has this name: get_all_feedback_needed_listings().

Duh, so long..